Oracle Import from CSV to existing table

I imported my CSV to a new table and everything worked fine.

I then truncated the data and attempted to reimport the same CSV file to the existing table.  When I select the tablename the import source shows the 8 columns, the Target column only matches the first element while the remaining 7 show <SKIP>.  The dropdown for  the target column only shows <SKIP> and the first column.

Am I doing something wrong?

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Would it be possible to share the CSV file with me?

  • Hopefully this is simple, I reduced the data to 2 rows.  I imported the file as a new table and let the tool select the datatypes, I changed the column SAMPLE_POSITION to allow nulls.

    Check - First row contains column names;

    File Encoding: Auto Detect

    Column Separator: Auto

    The tool said it was assigning the following new column types:

    JOB                nvarchar(8)
    RUN                nvarchar(2)
    SAMPLE_NAME        nvarchar(8)
    SAMPLE_POSITION    nvarchar(1)
    METHOD_TYPE        nvarchar(8)
    DATA_FILE          nvarchar(16)
    INJ_VOL            integer
    ACQ_TIME           nvarchar(32) for now lets keep this as a string

    New Table: AA -  2 rows imported.

    I then truncated the table:    

    truncate table AA;

    I then tried to reimported the CSV selecting the table AA, but the image above was shown.

  • I downloaded v2020.08 (Build 110632) just to see if that took care of the issue and it DID!!

    Not sure it was suppose too, but thanks.

    • Chris Wolcott ahhhhhh, that makes sense. I made a similar fix for postgres in one fo the last releases and that fix would have affected all providers :) Happy to help lol.

Like Follow
  • Status Answered
  • 2 wk agoLast active
  • 4Replies
  • 16Views
  • 2 Following