Connection Failed Message

I used connect without issues, after some version upgrade, now I cannot login into the DB (MySQL 5.6.10 on AWS).

Tried deleting and recreating the connection. I noticed that before, we could specify the MySQL version (between 8 and 5). Now there's no place to specify the version.

18replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi. Which product are you using (SQLPro for MySQL or SQLPro Studio)? Is it from the App Store or website? When did the issue first occur? Just as a side note - SQLPro has never provided a choice between MySQL versions.

    Like
      • Luke S
      • Luke_S
      • 1 yr ago
      • Reported - view

      Kyle Hankinson 

      (Wow, thanks for the quick follow up)

      The product is SQLPro Studio, I am subscribed to the Setapp service. The issue first occurred last night, but I don't use this app every day.

      Like
  • Understood on the point of not having a choice of MySQL version in SQLPro Studio. The problem is still there, not being able to connect.

    Like
  • I'm having the same issue, and am also using the SetApp version.

    I have been doing some debug my side, and we use a ProxySQL frontend to a Percona backend. 

    The key issue i've spotted is that ProxySQL thinks i'm not supplying a password  (i.e. as per screenshot above).  But i've checked multiple times, and if i change the hostname on a bookmark to not go via proxySQL then it works.

    I found this article suggesting a change in MySQL auth plugin ... perhaps SQLPro has had a library update which has changed the default auth style?

    Looks like a possible solution would be to supply the following arg to the connection string:

    --default-auth=mysql_native_password

    But is there a way to specify advanced setting like this in SQLPro?

    Like
  • I managed to restore to a Time Machine backup of SQLStudio Pro v 1.0.336, and the bookmarks have started working again. 

    Like
  • Mark MackayLuke S

    Hi. Can you try https://d3fwkemdw8spx3.cloudfront.net/studio/SQLProStudio.1.0.419.app.zip? If that sorts the trick, I will update the Setapp build.

    Like
    • Kyle Hankinson No joy with Version 1.0.419 (Build 110419) for me.

      Same error: "ProxySQL Error: Access denied for user 'xxx'@'xxx' (using password: NO)"

      Like
      • Luke S
      • Luke_S
      • 1 yr ago
      • Reported - view

      Kyle Hankinson sorry, problem still persists for me too.

      Like
  • I've been investigating, but I don't have a solution available as of yet. I hope to have another test build available early next week.

    Like 1
    • Kyle Hankinson In the interim, is there a way to disable auto-update?  My 1.0.336 build keeps self-updating to new version and breaking things again.

      Like
  • Hey Kyle Hankinson  - Any progress on this issue?  
    Still getting same error with Version 1.0.455 (Build 110455)

    Is there a file or something we could edit to get the app to use the "--default-auth=mysql_native_password" parameter, and see if that fixes it?

    Like
    • Mark Mackay hope to have a testing build available for this tomorrow.

      Like
    • Mark Mackay Could you try https://d3fwkemdw8spx3.cloudfront.net/studio/SQLProStudio.2019.04.30.app.zip? If that fails to connect, could you provide me with the log file?

      Like
    • Kyle Hankinson Bingo!  That build seems to work in my initial testing. 😄

      Like
    • Mark Mackay jeff. hermon  Luke S thanks! FYI the build will also be available via setapp soon. (I think some were using that).

      Like
    • SetApp build updated this morning and has fixed the problem for me.  Thanks Kyle Hankinson !

      Like
Like Follow
  • 11 mths agoLast active
  • 18Replies
  • 108Views
  • 3 Following